Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5


Nobody can ping my computer! How to enable ICMP Echo Request for ICMPv4
19-01-2012, 01:58 PM (This post was last modified: 08-04-2014 12:24 PM by Mark.)
Post: #1
Nobody can ping my computer! How to enable ICMP Echo Request for ICMPv4

Unable to ping my computer! How to enable ICMP Echo Request for ICMPv4

This applies To: Windows Vista, Windows 7, Windows Server 2008 and Windows Server 2008 R2.
A common troubleshooting step when testing connectivity is to use the Ping tool.
When you ping, you send an ICMP Echo message (also known as an ICMP Echo Request message) and get an ICMP Echo Reply message in response.
By default the Windows Firewall does not allow incoming ICMP Echo messages.


Steps

1. In the Windows Firewall with Advanced Security snap-in, click Inbound Rules in the tree, and click New Rule in the Actions Pane.

2. Click Custom and click Next.

3. Click All programs and click Next.

4. For Protocol type, select ICMPv4.

5. Click Customise for Internet Control Message Protocol (ICMP) settings.

6. Click Echo Request, click OK, and then click Next.

7. Any IP address

8. Click Allow the connection, and then click Next.

9. Under When does this rule apply click the active profile, any or all profiles (Domain, Private, Public) to which you want this rule to apply, and then click Next.

10. Type a name / description for the rule and click finish.

11. Repeat steps for ICMPv6, selecting ICMPv6 for Protocol Type instead of ICMPv4.



[Image: engrish25.png]
Reply



Forum Jump:


User(s) browsing this thread: 1 Guest(s)