Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5


CD / DVD drive not detected in OpenSuse 12.1
06-04-2012, 05:25 PM (This post was last modified: 06-04-2012 06:17 PM by howtothings.)
Post: #1
CD / DVD drive not detected in OpenSuse 12.1
On an OpenSuse box, (not mine!), it's not detecting that there's a CD drive plugged in.

The drive works in the BIOS and to install media from (install suse from it) but as soon as you log in it's not detected.

I've added the member to the "cdrom" group but still nothing, I've also tried logging in as root but that didn't work either.

[code=bash]mark@opensusesrv:~> mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=4045792k,nr_inodes=1011448,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda1 on / type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=23,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
/dev/sda2 on /tmp type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
/dev/sda3 on /home type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
/dev/sda6 on /vm type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfs-fuse-daemon on /home/mark/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
[/code]


Code:
udisks --dump
shows in detail the HHD partitions but nothing else.

Code:
mark@opensusesrv:/media> ls -l
total 0

Code:
mark@opensusesrv:/mnt> ls -l
total 0

Code:
mark@opensusesrv:/> mount|grep ^'/dev'
/dev/sda1 on / type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
/dev/sda2 on /tmp type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
/dev/sda3 on /home type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
/dev/sda6 on /vm type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)

Code:
opensusesrv:/ # mount -o ro -t iso9660 /dev/cdrom /cdrom
mount: special device /dev/cdrom does not exist

Code:
opensusesrv:/ # wodim --devices
wodim: Overview of accessible drives (0 found) :
-------------------------------------------------------------------------
-------------------------------------------------------------------------

Testing ISO9660 support
Code:
opensusesrv:/ # cat /proc/filesystems | grep iso9660
        iso9660

[code=bash]opensusesrv:/ # ls /dev/
agpgart hugepages mem sda2 tty12 tty3 tty47 tty7 vcs2
autofs initctl mqueue sda3 tty13 tty30 tty48 tty8 vcs3
block input net sda4 tty14 tty31 tty49 tty9 vcs4
bootsplash kmem network_latency sda5 tty15 tty32 tty5 ttyS0 vcs5
bsg kmsg network_throughput sda6 tty16 tty33 tty50 ttyS1 vcs6
btrfs-control log null sda7 tty17 tty34 tty51 ttyS2 vcs7
bus loop0 nvram sg0 tty18 tty35 tty52 ttyS3 vcsa
char loop1 oldmem shm tty19 tty36 tty53 ttyS4 vcsa1
console loop2 parport0 snapshot tty2 tty37 tty54 ttyS5 vcsa10
core loop3 port snd tty20 tty38 tty55 ttyS6 vcsa2
cpu loop4 ppp stderr tty21 tty39 tty56 ttyS7 vcsa3
cpu_dma_latency loop5 psaux stdin tty22 tty4 tty57 uinput vcsa4
disk loop6 ptmx stdout tty23 tty40 tty58 urandom vcsa5
dri loop7 pts .sysconfig tty24 tty41 tty59 vboxdrv vcsa6
fb0 loop-control random tty tty25 tty42 tty6 vboxnetctl vcsa7
fd lp0 rtc tty0 tty26 tty43 tty60 vboxusb vga_arbiter
full mapper rtc0 tty1 tty27 tty44 tty61 vcs watchdog
fuse mcelog sda tty10 tty28 tty45 tty62 vcs1 xconsole
hpet mei sda1 tty11 tty29 tty46 tty63 vcs10 zero
[/code]

[code=bash]opensusesrv:/ # cat /etc/fstab
/dev/disk/by-id/ata-SAMSUNG_HD204UI_S2H7J90ZB02040-part1 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-SAMSUNG_HD204UI_S2H7J90ZB02040-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_HD204UI_S2H7J90ZB02040-part3 /home ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-SAMSUNG_HD204UI_S2H7J90ZB02040-part2 /tmp ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-SAMSUNG_HD204UI_S2H7J90ZB02040-part6 /vm ext4 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
[/code]

Code:
Device Name    Device File
CD Drive    /dev/cdrom -> sr0
DVD Drive    /dev/dvd -> sr0
DVD RW Drive    /dev/dvdrw -> sr0
1st Floppy Drive    /dev/fd/0 -> /dev/pts/0
2nd Floppy Drive    /dev/fd/1 -> /dev/pts/0
USB Drive    /dev/sda or /dev/sdb


It's an internal SATA DVD drive.

Any ideas?


Just tried my USB external DVD drive

Code:
mark@opensusesrv:~> wodim --devices
wodim: Overview of accessible drives (1 found) :
-------------------------------------------------------------------------
0  dev='/dev/sg1'      rwrw-- : 'TSSTcorp' 'CDDVDW SE-S084F'
-------------------------------------------------------------------------


[Image: engrish25.png]
Reply
19-05-2012, 04:02 PM
Post: #2
RE: CD / DVD drive not detected in OpenSuse 12.1
Going off the fact that a USB DVD drive worked I bought a USB to IDE / SATA adapter and now it works no problem..


[Image: engrish25.png]
Reply



Forum Jump:


User(s) browsing this thread: 1 Guest(s)